<!DOCTYPE html>
<html lang="en-US"
 xmlns:fb="http://ogp.me/ns/fb#">
<head>
<meta charset="UTF-8" >
<meta name="viewport" id="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, minimum-scale=1.0, user-scalable=no" />
<link rel="shortcut icon" href="https://sunrise.ug/wp-content/uploads/2015/05/favicon.ico" /><link rel="pingback" href="https://sunrise.ug/xmlrpc.php" />
<meta property="og:image" content="https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala-clip.jpg" />
<meta name="twitter:image" content="https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala-clip.jpg" />
<meta property="og:type" content="article" />
<meta property="og:description" content="In his 2019 autobiography titled, Double Your Money: Reflections on the Life of a Ugandan Agro Businessman, Aga Sekalala Snr paints a wonderful, intriguing picture of personal and business life in Uganda, both at independence and post-independence. He recalls working alongside his father &#8211; as a child &#8211; in a makeshift coffee processing business in [&hellip;]" />
<meta name="twitter:card" content="summary">
<meta name="twitter:url" content="https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html">
<meta name="twitter:title" content="Uganda@60: It’s a story of shared dreams and struggles">
<meta name="twitter:description" content="In his 2019 autobiography titled, Double Your Money: Reflections on the Life of a Ugandan Agro Businessman, Aga Sekalala Snr paints a wonderful, intriguing picture of personal and business life in Uganda, both at independence and post-independence. He recalls working alongside his father &#8211; as a child &#8211; in a makeshift coffee processing business in [&hellip;]">
<title>Uganda@60: It’s a story of shared dreams and struggles &#8211; Sunrise</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Sunrise &raquo; Feed" href="https://sunrise.ug/feed" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.9.1 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script
				src="//www.googletagmanager.com/gtag/js?id=UA-62751529-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/sunrise.ug\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='ppress-frontend-css'  href='https://sunrise.ug/wp-content/plugins/wp-user-avatar/assets/css/frontend.min.css?ver=4.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-flatpickr-css'  href='https://sunrise.ug/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.css?ver=4.2.0' type='text/css' media='all' />
<link rel='stylesheet' id='ppress-select2-css'  href='https://sunrise.ug/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-custom-style-css'  href='https://sunrise.ug/wp-content/themes/sunrise1/style.css?ver=6.0.2' type='text/css' media='all' />
<style id='mvp-custom-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='mvp-reset-css'  href='https://sunrise.ug/wp-content/themes/sunrise1/css/reset.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='https://sunrise.ug/wp-content/themes/sunrise1/font-awesome/css/font-awesome.css?ver=6.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-fonts-css'  href='//fonts.googleapis.com/css?family=Oswald%3A300%2C400%2C700%7CMerriweather%3A300%2C400%2C700%2C900%7CQuicksand%3A400%7CLato%3A300%2C400%2C700%7CPassion+One%3A400%2C700%7CWork+Sans%3A200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CMontserrat%3A400%2C700%7COpen+Sans+Condensed%3A300%2C700%7COpen+Sans%3A400%2C700%2C800%7CWork+Sans%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CWork+Sans%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%7CWork+Sans%3A100%2C200%2C300%2C400%2C400italic%2C500%2C600%2C700%2C700italic%2C800%2C900%7CMerriweather%3A100%2C200%2C300%2C400%2C400italic%2C500%2C600%2C700%2C700italic%2C800%2C900%7CWork+Sans%3A100%2C200%2C300%2C400%2C500%2C600%2C700%2C800%2C900%26subset%3Dlatin%2Clatin-ext%2Ccyrillic%2Ccyrillic-ext%2Cgreek-ext%2Cgreek%2Cvietnamese&#038;ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='mvp-media-queries-css'  href='https://sunrise.ug/wp-content/themes/sunrise1/css/media-queries.css?ver=6.0.2' type='text/css' media='all' />
<script type='text/javascript' src='https://sunrise.ug/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.9.1' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/sunrise.ug","hash_tracking":"false","ua":"UA-62751529-1","v4_id":""};/* ]]> */
</script>
<script type='text/javascript' src='https://sunrise.ug/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://sunrise.ug/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://sunrise.ug/wp-content/plugins/wp-user-avatar/assets/flatpickr/flatpickr.min.js?ver=4.2.0' id='ppress-flatpickr-js'></script>
<script type='text/javascript' src='https://sunrise.ug/wp-content/plugins/wp-user-avatar/assets/select2/select2.min.js?ver=4.2.0' id='ppress-select2-js'></script>
<link rel="https://api.w.org/" href="https://sunrise.ug/wp-json/" /><link rel="alternate" type="application/json" href="https://sunrise.ug/wp-json/wp/v2/posts/36884" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://sunrise.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://sunrise.ug/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 6.0.2" />
<link rel="canonical" href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html" />
<link rel='shortlink' href='https://sunrise.ug/?p=36884' />
<link rel="alternate" type="application/json+oembed" href="https://sunrise.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsunrise.ug%2Fopinions%2Fcolumnists%2Fbeautiful-chaos%2F202210%2Fuganda60-its-a-story-of-shared-dreams-and-struggles.html" />
<link rel="alternate" type="text/xml+oembed" href="https://sunrise.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsunrise.ug%2Fopinions%2Fcolumnists%2Fbeautiful-chaos%2F202210%2Fuganda60-its-a-story-of-shared-dreams-and-struggles.html&#038;format=xml" />
<meta property="fb:app_id" content="275960799532366"/></head>
<body class="post-template-default single single-post postid-36884 single-format-standard">
	<div id="mvp-fly-wrap">
	<div id="mvp-fly-menu-top" class="left relative">
		<div class="mvp-fly-top-out left relative">
			<div class="mvp-fly-top-in">
				<div id="mvp-fly-logo" class="left relative">
											<a href="https://sunrise.ug/"><img src="https://sunrise.ug/wp-content/uploads/2017/07/logo-nav-1.png" alt="Sunrise" data-rjs="2" /></a>
									</div><!--mvp-fly-logo-->
			</div><!--mvp-fly-top-in-->
			<div class="mvp-fly-but-wrap mvp-fly-but-menu mvp-fly-but-click">
				<span></span>
				<span></span>
				<span></span>
				<span></span>
			</div><!--mvp-fly-but-wrap-->
		</div><!--mvp-fly-top-out-->
	</div><!--mvp-fly-menu-top-->
	<div id="mvp-fly-menu-wrap">
		<nav class="mvp-fly-nav-menu left relative">
			<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-1308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1308"><a href="https://sunrise.ug">Home</a></li>
<li id="menu-item-1248" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1248"><a href="https://sunrise.ug/category/business">Business</a>
<ul class="sub-menu">
	<li id="menu-item-1249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1249"><a href="https://sunrise.ug/category/business/corporate">Corporate</a></li>
</ul>
</li>
<li id="menu-item-1252" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1252"><a href="https://sunrise.ug/category/news">News</a>
<ul class="sub-menu">
	<li id="menu-item-1263" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1263"><a href="https://sunrise.ug/category/news/sports">Sports</a></li>
	<li id="menu-item-1253" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1253"><a href="https://sunrise.ug/category/news/analysis">Analysis</a></li>
	<li id="menu-item-1254" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1254"><a href="https://sunrise.ug/category/news/features">human traffickingFeatures</a></li>
	<li id="menu-item-1255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1255"><a href="https://sunrise.ug/category/news/health">Health</a></li>
</ul>
</li>
<li id="menu-item-1250" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1250"><a href="https://sunrise.ug/category/gossip">Gossip</a></li>
<li id="menu-item-1251" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1251"><a href="https://sunrise.ug/category/life-style">Life &#038; Style</a>
<ul class="sub-menu">
	<li id="menu-item-1264" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1264"><a href="https://sunrise.ug/category/life-style/travel">Travel</a>
	<ul class="sub-menu">
		<li id="menu-item-1265" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1265"><a href="https://sunrise.ug/category/life-style/travel/airlines">Airlines</a></li>
		<li id="menu-item-1266" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1266"><a href="https://sunrise.ug/category/life-style/travel/national-parks">National Parks</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-1256" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-1256"><a href="https://sunrise.ug/category/opinions">Opinions</a>
<ul class="sub-menu">
	<li id="menu-item-1261" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1261"><a href="https://sunrise.ug/category/opinions/editorial">Editorial</a></li>
	<li id="menu-item-1257" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-1257"><a href="https://sunrise.ug/category/opinions/columnists">Columnists</a>
	<ul class="sub-menu">
		<li id="menu-item-1258" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1258"><a href="https://sunrise.ug/category/opinions/columnists/ikebesi-omoding">Ikebesi Omoding</a></li>
		<li id="menu-item-1259" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1259"><a href="https://sunrise.ug/category/opinions/columnists/isa-senkumba">Isa Senkumba</a></li>
		<li id="menu-item-1260" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1260"><a href="https://sunrise.ug/category/opinions/columnists/ramathan-ggoobi">Ramathan Ggoobi</a></li>
	</ul>
</li>
	<li id="menu-item-1262" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1262"><a href="https://sunrise.ug/category/opinions/letters">Letters</a></li>
</ul>
</li>
</ul></div>		</nav>
	</div><!--mvp-fly-menu-wrap-->
	<div id="mvp-fly-soc-wrap">
		<span class="mvp-fly-soc-head">Connect with us</span>
		<ul class="mvp-fly-soc-list left relative">
							<li><a href="https://www.facebook.com/sunriseug" target="_blank" class="fa fa-facebook-official fa-2"></a></li>
										<li><a href="https://twitter.com/TheSunriseUg" target="_blank" class="fa fa-twitter fa-2"></a></li>
																							</ul>
	</div><!--mvp-fly-soc-wrap-->
</div><!--mvp-fly-wrap-->		<div id="mvp-site" class="left relative">
		<header id="mvp-head-wrap" class="left relative">
			<div id="mvp-head-top" class="left relative">
									<div id="mvp-leader-wrap" class="left relative">
						<a href="https://www.health.go.ug/covid/"><img src="https://sunrise.ug/wp-content/uploads/2021/09/COVID19-vaccination-728X90.gif" alt="Ministry of health" width="720" height="90" name="Ministry" /></a>					</div><!--mvp-leader-wrap-->
												<div id="mvp-search-wrap">
					<div id="mvp-search-box">
						<form method="get" id="searchform" action="https://sunrise.ug/">
	<input type="text" name="s" id="s" value="Search" onfocus='if (this.value == "Search") { this.value = ""; }' onblur='if (this.value == "") { this.value = "Search"; }' />
	<input type="hidden" id="searchsubmit" value="Search" />
</form>					</div><!--mvp-search-box-->
					<div class="mvp-search-but-wrap mvp-search-click">
						<span></span>
						<span></span>
					</div><!--mvp-search-but-wrap-->
				</div><!--mvp-search-wrap-->
			</div><!--mvp-head-top-->
			<div id="mvp-nav-wrap" class="left relative">
				<div class="mvp-main-boxed-wrap">
					<div class="mvp-main-out relative">
						<div class="mvp-main-in">
							<div class="mvp-main-nav-cont left relative">
				<div class="mvp-nav-left-out">
					<div class="mvp-fly-but-wrap mvp-fly-but-click left relative">
						<span></span>
						<span></span>
						<span></span>
						<span></span>
					</div><!--mvp-fly-but-wrap-->
					<div id="mvp-logo-nav" class="left relative" itemscope itemtype="http://schema.org/Organization">
													<a itemprop="url" href="https://sunrise.ug/"><img itemprop="logo" src="https://sunrise.ug/wp-content/uploads/2017/07/logo-nav-1.png" alt="Sunrise" data-rjs="2" /></a>
																			<h2 class="mvp-logo-title">Sunrise</h2>
											</div><!--mvp-logo-nav-->
					<div class="mvp-nav-left-in">
						<div id="mvp-nav-right-wrap" class="left">
							<div class="mvp-nav-right-out">
								<div class="mvp-nav-right-in">
									<div id="mvp-nav-main" class="left">
										<nav id="mvp-nav-menu">
											<div class="menu-main-container"><ul id="menu-main-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1308"><a href="https://sunrise.ug">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1248"><a href="https://sunrise.ug/category/business">Business</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1249"><a href="https://sunrise.ug/category/business/corporate">Corporate</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1252"><a href="https://sunrise.ug/category/news">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1263"><a href="https://sunrise.ug/category/news/sports">Sports</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1253"><a href="https://sunrise.ug/category/news/analysis">Analysis</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1254"><a href="https://sunrise.ug/category/news/features">human traffickingFeatures</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1255"><a href="https://sunrise.ug/category/news/health">Health</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1250"><a href="https://sunrise.ug/category/gossip">Gossip</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1251"><a href="https://sunrise.ug/category/life-style">Life &#038; Style</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1264"><a href="https://sunrise.ug/category/life-style/travel">Travel</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1265"><a href="https://sunrise.ug/category/life-style/travel/airlines">Airlines</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1266"><a href="https://sunrise.ug/category/life-style/travel/national-parks">National Parks</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-1256"><a href="https://sunrise.ug/category/opinions">Opinions</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1261"><a href="https://sunrise.ug/category/opinions/editorial">Editorial</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-1257"><a href="https://sunrise.ug/category/opinions/columnists">Columnists</a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1258"><a href="https://sunrise.ug/category/opinions/columnists/ikebesi-omoding">Ikebesi Omoding</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1259"><a href="https://sunrise.ug/category/opinions/columnists/isa-senkumba">Isa Senkumba</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1260"><a href="https://sunrise.ug/category/opinions/columnists/ramathan-ggoobi">Ramathan Ggoobi</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1262"><a href="https://sunrise.ug/category/opinions/letters">Letters</a></li>
</ul>
</li>
</ul></div>										</nav><!--mvp-nav-menu-->
									</div><!--mvp-nav-main-->
								</div><!--mvp-nav-right-in-->
								<div id="mvp-nav-right" class="relative">
									<div id="mvp-nav-soc" class="left relative">
																					<a href="https://www.facebook.com/sunriseug" target="_blank"><span class="mvp-nav-soc-but fa fa-facebook fa-2"></span></a>
																															<a href="https://twitter.com/TheSunriseUg" target="_blank"><span class="mvp-nav-soc-but fa fa-twitter fa-2"></span></a>
																			</div><!--mvp-nav-soc-->
									<span class="mvp-nav-search-but fa fa-search fa-2 mvp-search-click"></span>

								</div><!--mvp-nav-right-->
							</div><!--mvp-nav-right-out-->
						</div><!--mvp-nav-right-wrap-->
					</div><!--mvp-nav-left-in-->
				</div><!--mvp-nav-left-out-->
							</div><!--mvp-main-nav-cont-->
						</div><!--mvp-main-in-->
					</div><!--mvp-main-out-->
				</div><!--mvp-main-boxed-wrap-->
			</div><!--mvp-nav-wrap-->
															<div id="mvp-nav-soc-bar">
					<div class="mvp-main-out relative">
						<div class="mvp-main-in">
							<div id="mvp-nav-soc-cont" class="left relative">
								<div id="mvp-nav-soc-title" class="left">
									<h4>Uganda@60: It’s a story of shared dreams and struggles</h4>
								</div><!--mvp-nav-soc-title-->
								<div id="mvp-nav-soc-list" class="left">
<ul class="mvp-post-soc-list left relative">
												<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html&amp;t=Uganda@60: It’s a story of shared dreams and struggles', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
												<li class="mvp-post-soc-fb">
													<i class="fa fa-facebook-square fa-2" aria-hidden="true"></i><span class="mvp-post-soc-text">Share</span>
												</li>
												</a>
												<a href="#" onclick="window.open('http://twitter.com/share?text=Uganda@60: It’s a story of shared dreams and struggles -&amp;url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
												<li class="mvp-post-soc-twit">
													<i class="fa fa-twitter fa-2" aria-hidden="true"></i><span class="mvp-post-soc-text">Tweet</span>
												</li>
												</a>
												<a href="whatsapp://send?text=Uganda@60: It’s a story of shared dreams and struggles https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html">
												<li class="mvp-post-soc-what">
													<i class="fa fa-whatsapp fa-2" aria-hidden="true"></i>
												</li>
												</a>
												<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html&amp;media=https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala-clip.jpg&amp;description=Uganda@60: It’s a story of shared dreams and struggles', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
												<li class="mvp-post-soc-pin">
													<i class="fa fa-pinterest-p fa-2" aria-hidden="true"></i>
												</li>
												</a>
												<a href="mailto:?subject=Uganda@60: It’s a story of shared dreams and struggles&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html">
												<li class="mvp-post-soc-email">
													<i class="fa fa-envelope-o fa-2" aria-hidden="true"></i>
												</li>
												</a>
											</ul>
								</div><!--mvp-nav-soc-list-->
							</div><!--mvp-nav-soc-cont-->
						</div><!--mvp-main-in-->
					</div><!--mvp-main-out-->
				</div><!--mvp-nav-soc-bar-->
													</header><!--mvp-head-wrap-->
		<div id="mvp-main-wrap" class="left relative">
			<div class="mvp-main-boxed-wrap">
				<div class="mvp-main-out relative">
					<div class="mvp-main-in">
						<div id="mvp-main-content-wrap" class="left relative"><div id="mvp-post-area" class="post-36884 post type-post status-publish format-standard has-post-thumbnail hentry category-beautiful-chaos tag-featured tag-ugachick">
	<div class="mvp-content-side-out relative">
		<div class="mvp-content-side-in">
			<div id="mvp-content-left-wrap" class="left relative">
						<article id="mvp-post-content-wrap" class="left relative" itemscope itemtype="http://schema.org/NewsArticle">
				<meta itemscope itemprop="mainEntityOfPage"  itemType="https://schema.org/WebPage" itemid="https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html"/>
									<div class="mvp-post-img-hide" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
												<meta itemprop="url" content="https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala-clip.jpg">
						<meta itemprop="width" content="460">
						<meta itemprop="height" content="426">
					</div><!--mvp-post-img-hide-->
								<div id="mvp-post-content" class="left relative">
					<div class="mvp-post-content-out relative">
													<div id="mvp-post-info-col" class="left relative">
															</div><!--mvp-post-info-col-->
												<div class="mvp-post-content-in">
							<div id="mvp-post-content-mid" class="left relative">
																				<header id="mvp-post-head" class="left relative">
																			<a class="mvp-post-cat-link" href="https://sunrise.ug/category/opinions/columnists/beautiful-chaos"><h3 class="mvp-post-cat left"><span class="mvp-post-cat left">Brian Mukalazi</span></h3></a>
										<h1 class="mvp-post-title entry-title" itemprop="headline">Uganda@60: It’s a story of shared dreams and struggles</h1>
																											<div id="mvp-post-info-wrap" class="left relative">
										<div id="mvp-post-info-top" class="left relative">
											<div class="mvp-post-info-out right relative">
												<div id="mvp-post-author-img" class="left relative">
													<img data-del="avatar" src='https://sunrise.ug/wp-content/uploads/2021/08/PSX_20210809_175546-100x100.jpg' class='avatar pp-user-avatar avatar-45 photo ' height='45' width='45'/>												</div><!--mvp-post-author-img-->
												<div class="mvp-post-info-in">
													<div id="mvp-post-author" class="left relative" itemprop="author" itemscope itemtype="https://schema.org/Person">
														<p>By<p><span class="author-name vcard fn author" itemprop="name"><a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span> <span class="mvp-author-twit"><a href="@Mukalazibryan" class="twitter-but" target="_blank"><i class="fa fa-twitter fa-2"></i></a></span> 													</div><!--mvp-post-author-->
													<div id="mvp-post-date" class="left relative">
														<span class="post-info-text">Published on</span> <span class="post-date updated"><time class="post-date updated" itemprop="datePublished" datetime="2022-10-09">October 9, 2022</time></span>
														<meta itemprop="dateModified" content="2022-10-11"/>
													</div><!--mvp-post-date-->
												</div><!--mvp-post-info-in-->
											</div><!--mvp-post-info-out-->
										</div><!--mvp-post-info-top-->
																				<div id="mvp-post-info-bot" class="right relative">
											<ul class="mvp-post-soc-list left relative">
												<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html&amp;t=Uganda@60: It’s a story of shared dreams and struggles', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook">
												<li class="mvp-post-soc-fb">
													<i class="fa fa-facebook-square fa-2" aria-hidden="true"></i><span class="mvp-post-soc-text">Share</span>
												</li>
												</a>
												<a href="#" onclick="window.open('http://twitter.com/share?text=Uganda@60: It’s a story of shared dreams and struggles -&amp;url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post">
												<li class="mvp-post-soc-twit">
													<i class="fa fa-twitter fa-2" aria-hidden="true"></i><span class="mvp-post-soc-text">Tweet</span>
												</li>
												</a>
												<a href="whatsapp://send?text=Uganda@60: It’s a story of shared dreams and struggles https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html">
												<li class="mvp-post-soc-what">
													<i class="fa fa-whatsapp fa-2" aria-hidden="true"></i>
												</li>
												</a>
												<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html&amp;media=https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala-clip.jpg&amp;description=Uganda@60: It’s a story of shared dreams and struggles', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post">
												<li class="mvp-post-soc-pin">
													<i class="fa fa-pinterest-p fa-2" aria-hidden="true"></i>
												</li>
												</a>
												<a href="mailto:?subject=Uganda@60: It’s a story of shared dreams and struggles&amp;BODY=I found this article interesting and thought of sharing it with you. Check it out: https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html">
												<li class="mvp-post-soc-email">
													<i class="fa fa-envelope-o fa-2" aria-hidden="true"></i>
												</li>
												</a>
																							</ul>
										</div><!--mvp-post-info-bot-->
																			</div><!--mvp-post-info-wrap-->
								</header>
								<section id="mvp-content-main" itemprop="articleBody" class="post-36884 post type-post status-publish format-standard has-post-thumbnail hentry category-beautiful-chaos tag-featured tag-ugachick">
									<div id="attachment_33164" style="width: 638px" class="wp-caption aligncenter"><a href="https://sunrise.ug/wp-content/uploads/2021/04/PSX_20210419_162746.jpg"><img aria-describedby="caption-attachment-33164" loading="lazy" src="https://sunrise.ug/wp-content/uploads/2021/04/PSX_20210419_162746.jpg" alt="" width="628" height="363" class="size-full wp-image-33164" srcset="https://sunrise.ug/wp-content/uploads/2021/04/PSX_20210419_162746.jpg 628w, https://sunrise.ug/wp-content/uploads/2021/04/PSX_20210419_162746-300x173.jpg 300w" sizes="(max-width: 628px) 100vw, 628px" /></a><p id="caption-attachment-33164" class="wp-caption-text">Entebbe express way road toll</p></div>
<p>In his 2019 autobiography titled, <em>Double Your Money: Reflections on the Life of a Ugandan Agro Businessman</em>, Aga Sekalala Snr paints a wonderful, intriguing picture of personal and business life in Uganda, both at independence and post-independence. </p>
<p>He recalls working alongside his father &#8211; as a child &#8211; in a makeshift coffee processing business in the 1950s. He narrates his struggles with finding his first job and settling in Kampala after coming back from London in the 1960s shortly after independence.<br />
<a href="https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala.jpg"><img loading="lazy" src="https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala.jpg" alt="" width="460" height="630" class="alignleft size-full wp-image-36885" srcset="https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala.jpg 460w, https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala-219x300.jpg 219w" sizes="(max-width: 460px) 100vw, 460px" /></a> </p>
<p>He goes ahead and tells us how he met and married his wife. “I did not have any pre-wedding meetings, or fundraising drives, in preparation for my wedding. I had planned to use the money overpaid to my scholarship …which was about 3,000 shillings. I invited only 15 people…”, he says.</p>
<p>He describes his time working for The Management Training and Advisory Center (MTAC) and how he used his creativity and diligence to rise to the highest office. And how he left this comfortable, well-paying job in 1972, when then president Idi Amin Dada, expelled Asians from Uganda, for the world of business.  </p>
<p>He also gives a detailed account of the difficult economic times he has experienced over the past six decades right from his first business (a fuel outlet along Parliamentary Avenue) to others that he has established to-date, most notably Ugachick. </p>
<p>Well, many of our readers could argue that Aga Sekalala Snr is by no means an ordinary Ugandan as he is ranked among the most successful people in the country. That is true. But if you read his book, especially the not-so-old people, you get a clearer understanding of the ‘then and now’ of our country. </p>
<p>The times have obviously changed but some things have almost remained intact. In my opinion, the dreams, aspirations and struggles of present-day Ugandans, are not significantly different from those who lived by 1962.    </p>
<p>Like the Aga Sekalala Snr of the 1960s, we have millions of young people today with deep entrepreneurial spirit and business acumen. We still have honest and resilient people who want to get ahead in life. But again, we still battle with similar challenges of unemployment, loose economic institutions and moral failure, among others.</p>
<p>For many years, Uganda has demonstrated strong entrepreneurship, innovation and investment potential. One recent notable showcase of this was the resilience of a number of start-ups that weathered the storm as Uganda and the world quaked under the Covid-19 global pandemic. The ingenious innovations and swift solutions devised during this period have demonstrated the power of this potential. </p>
<p>But on the flip side, I have also realized that, in our country, it is much harder to stay in business than starting it. It is harder to keep a company’s momentum, to shift its speed and to alter its direction. It is harder to make decisions, because so many additional factors have to be considered and it is harder to get them executed.   </p>
<p>In the 1960s, a man’s wealth was measured by the size of his herd, coffee or banana plantations, which were largely handled on a subsistence basis with rudimentary tools. Many livelihoods were dependent on land than on paid work. Today, the situation is not any different, only that land is scarcer with worse environmental conditions and agriculture is a harder undertaking.  </p>
<p>Although agriculture continues to employ some 70 percent of Uganda’s labour, its contribution to the country’s GDP has shrunk. Its growth has been muted by the long-known issues of limited commercialization, value-addition and trade.</p>
<p>Diseases such as HIV/AIDS continue to ravage Ugandan communities even after 40-or-so years since its discovery. The difference is that public attitudes towards AIDS have transitioned from fear, horror and dread, to familiarity and seeing it as just another infectious disease, in light of the arsenal of drugs developed to suppress it.</p>
<p>But while it is easy to forget the shocking sight of the first AIDS patients in the 1980s and the dismay they provoked, present-day Ugandans cannot forget or ignore the recent run of pandemics and epidemics (COVID-19, EBOLA, etc.) experienced despite the extraordinary advances in medical science. We can’t be complacent about the threat of these new diseases. </p>
<p>Ugandans, we have surely come from afar. We have been through civil wars, plagues and epidemics and all sorts of economic and political downturns. But not all is doom and gloom because over the years, we have also had some key achievements, say with women emancipation (where women and girls have been given more opportunities to thrive), economy, political stability and infrastructure development.  </p>
<p>Perhaps the core difference between the Uganda of now and then is the generational transition. Unlike 60 years ago, the world today is more volatile, uncertain, complex and ambiguous. </p>
<p>Therefore, as we celebrate these 60 years of independence, let’s reflect: Let’s accept our past mistakes. Let’s take these observations with grace and earnestness, let’s be eager to do the hard work of transformation, and let’s avoid the temptation of denial or defence. If we do not do some of these things, the consequences of our past will become more and more apparent in the journey ahead. </p>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ --><h3>Comments</h3><p><fb:comments-count href=https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html></fb:comments-count> comments</p><div class="fb-comments" data-href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html" data-numposts="5" data-width="100%" data-colorscheme="light"></div>																										</section><!--mvp-content-main-->
								<div id="mvp-ad-rel-wrap">
									<div id="mvp-ad-rel-top" class="left relative">
										<span class="mvp-ad-rel-but mvp-ad-rel-click">Continue Reading</span>
									</div><!--mvp-ad-rel-top-->
									<div id="mvp-ad-rel-bot" class="left relative">
										<div class="mvp-ad-rel-out right relative">
																							<div id="mvp-post-bot-ad" class="left relative">
													<span class="mvp-ad-label">Advertisement</span>
													<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-format="fluid"
     data-ad-layout="in-article"
     data-ad-client="ca-pub-9795369121344126"
     data-ad-slot="1632126978"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>												</div><!--mvp-post-bot-ad-->
																						<div class="mvp-ad-rel-in">
																									<div id="mvp-post-bot-rel" class="left relative">
														<span class="mvp-related-head left relative">You may also like...</span>
																											</div><!--mvp-post-bot-rel-->
																							</div><!--mvp-ad-rel-in-->
										</div><!--mvp-ad-rel-out-->
									</div><!--mvp-ad-rel-bot-->
								</div><!--mvp-ad-rel-wrap-->
								<div class="mvp-post-tags">
									<span class="mvp-post-tags-header">Related Topics:</span><span itemprop="keywords"><a href="https://sunrise.ug/tag/featured" rel="tag">featured</a>, <a href="https://sunrise.ug/tag/ugachick" rel="tag">Ugachick</a></span>
								</div><!--mvp-post-tags-->
								<div class="posts-nav-link">
																	</div><!--posts-nav-link-->
																	<div id="mvp-author-box-wrap" class="left relative">
										<div class="mvp-author-box-out right relative">
											<div id="mvp-author-box-img" class="left relative">
												<img data-del="avatar" src='https://sunrise.ug/wp-content/uploads/2021/08/PSX_20210809_175546-100x100.jpg' class='avatar pp-user-avatar avatar-100 photo ' height='100' width='100'/>											</div><!--mvp-author-box-img-->
											<div class="mvp-author-box-in">
												<div id="mvp-author-box-text" class="left relative">
													<span class="mvp-author-box-name left relative"><a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span>
													<p></p>
									<div id="mvp-author-box-soc-wrap" class="left relative">
																															<a href="https://facebook.com/MukalaziBryan" alt="Facebook" target="_blank"><span class="mvp-author-box-soc fa fa-facebook-square fa-2"></span></a>
																															<a href="@Mukalazibryan" alt="Twitter" target="_blank"><span class="mvp-author-box-soc fa fa-twitter-square fa-2"></span></a>
																																																											</div><!--mvp-author-box-soc-wrap-->
												</div><!--mvp-author-box-text-->
											</div><!--mvp-author-box-in-->
										</div><!--mvp-author-box-out-->
									</div><!--mvp-author-box-wrap-->
																<div class="mvp-org-wrap" itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
									<div class="mvp-org-logo" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
																					<img src="https://sunrise.ug/wp-content/uploads/2017/07/logo-nav.png"/>
											<meta itemprop="url" content="https://sunrise.ug/wp-content/uploads/2017/07/logo-nav.png">
																			</div><!--mvp-org-logo-->
									<meta itemprop="name" content="Sunrise">
								</div><!--mvp-org-wrap-->
															</div><!--mvp-post-content-mid-->
						</div><!--mvp-post-content-in-->
					</div><!--mvp-post-content-out-->
				</div><!--mvp-post-content-->
			</article><!--mvp-post-content-wrap-->
												<div id="mvp-post-bot-wrap" class="left relative">
				<h4 class="mvp-post-bot-head left">More in Brian Mukalazi</h4>
				<section class="mvp-main-blog-wrap left relative">
					<ul class="mvp-main-blog-story left relative">
											<li>
						<div class="mvp-main-blog-out relative">
							<a href="https://sunrise.ug/news/202209/about-uganda-the-drunken-nation.html" rel="bookmark">
							<div class="mvp-main-blog-img left relative">
																	<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/09/PSX_20220906_123805-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" />									<img width="100" height="100" src="https://sunrise.ug/wp-content/uploads/2022/09/PSX_20220906_123805-100x100.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://sunrise.ug/wp-content/uploads/2022/09/PSX_20220906_123805-100x100.jpg 100w, https://sunrise.ug/wp-content/uploads/2022/09/PSX_20220906_123805-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" />																							</div><!--mvp-main-blog-img-->
							</a>
							<div class="mvp-main-blog-in">
								<div class="mvp-main-blog-text left relative">
									<h3 class="mvp-main-blog-cat left"><span class="mvp-main-blog-cat left">Brian Mukalazi</span></h3>
									<a href="https://sunrise.ug/news/202209/about-uganda-the-drunken-nation.html" rel="bookmark"><h2>About Uganda, the drunken Nation!</h2></a>
									<div class="mvp-feat1-info">
										<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><time class="mvp-blog-time">September 6, 2022</time></span>
									</div><!--mvp-feat1-info-->
									<p>Curious to know the highest alcohol-consuming countries in the world? Well, if you’re a Ugandan, you...</p>
									<div class="mvp-story-share-wrap">
										<span class="mvp-story-share-but fa fa-share fa-2"></span>
										<div class="mvp-story-share-cont">
											<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://sunrise.ug/news/202209/about-uganda-the-drunken-nation.html&t=About Uganda, the drunken Nation!', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mvp-story-share-fb fa fa-facebook fa-2"></span></a>
											<a href="#" onclick="window.open('http://twitter.com/share?text=About Uganda, the drunken Nation! -&url=https://sunrise.ug/news/202209/about-uganda-the-drunken-nation.html', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mvp-story-share-twit fa fa-twitter fa-2"></span></a>
											<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://sunrise.ug/news/202209/about-uganda-the-drunken-nation.html&amp;media=https://sunrise.ug/wp-content/uploads/2022/09/PSX_20220906_123805.jpg&amp;description=About Uganda, the drunken Nation!', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mvp-story-share-pin fa fa-pinterest-p fa-2"></span></a>
										</div><!--mvp-story-share-cont-->
									</div><!--mvp-story-share-wrap-->
								</div><!--mvp-main-blog-text-->
							</div><!--mvp-main-blog-in-->
						</div><!--mvp-main-blog-out-->
					</li>
											<li>
						<div class="mvp-main-blog-out relative">
							<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/ugandas-job-market-its-about-who-you-know.html" rel="bookmark">
							<div class="mvp-main-blog-img left relative">
																	<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/08/Uganda-Airlines_CEO-Jennifer-Bamuturaki-and-COSASE-Chair-Joel-Ssenyonyi-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" />									<img width="100" height="100" src="https://sunrise.ug/wp-content/uploads/2022/08/Uganda-Airlines_CEO-Jennifer-Bamuturaki-and-COSASE-Chair-Joel-Ssenyonyi-100x100.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://sunrise.ug/wp-content/uploads/2022/08/Uganda-Airlines_CEO-Jennifer-Bamuturaki-and-COSASE-Chair-Joel-Ssenyonyi-100x100.jpg 100w, https://sunrise.ug/wp-content/uploads/2022/08/Uganda-Airlines_CEO-Jennifer-Bamuturaki-and-COSASE-Chair-Joel-Ssenyonyi-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" />																							</div><!--mvp-main-blog-img-->
							</a>
							<div class="mvp-main-blog-in">
								<div class="mvp-main-blog-text left relative">
									<h3 class="mvp-main-blog-cat left"><span class="mvp-main-blog-cat left">Brian Mukalazi</span></h3>
									<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/ugandas-job-market-its-about-who-you-know.html" rel="bookmark"><h2>Uganda’s job market: It’s about who you know!</h2></a>
									<div class="mvp-feat1-info">
										<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><time class="mvp-blog-time">August 22, 2022</time></span>
									</div><!--mvp-feat1-info-->
									<p>I am quite sure that many of our readers have heard of this popular adage: &#8220;It&#8217;s...</p>
									<div class="mvp-story-share-wrap">
										<span class="mvp-story-share-but fa fa-share fa-2"></span>
										<div class="mvp-story-share-cont">
											<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/ugandas-job-market-its-about-who-you-know.html&t=Uganda’s job market: It’s about who you know!', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mvp-story-share-fb fa fa-facebook fa-2"></span></a>
											<a href="#" onclick="window.open('http://twitter.com/share?text=Uganda’s job market: It’s about who you know! -&url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/ugandas-job-market-its-about-who-you-know.html', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mvp-story-share-twit fa fa-twitter fa-2"></span></a>
											<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/ugandas-job-market-its-about-who-you-know.html&amp;media=https://sunrise.ug/wp-content/uploads/2022/08/Uganda-Airlines_CEO-Jennifer-Bamuturaki-and-COSASE-Chair-Joel-Ssenyonyi.jpg&amp;description=Uganda’s job market: It’s about who you know!', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mvp-story-share-pin fa fa-pinterest-p fa-2"></span></a>
										</div><!--mvp-story-share-cont-->
									</div><!--mvp-story-share-wrap-->
								</div><!--mvp-main-blog-text-->
							</div><!--mvp-main-blog-in-->
						</div><!--mvp-main-blog-out-->
					</li>
											<li>
						<div class="mvp-main-blog-out relative">
							<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/lessons-from-the-mbale-floods-disaster.html" rel="bookmark">
							<div class="mvp-main-blog-img left relative">
																	<img width="352" height="240" src="https://sunrise.ug/wp-content/uploads/2022/08/PSX_20220809_091504-352x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" srcset="https://sunrise.ug/wp-content/uploads/2022/08/PSX_20220809_091504-352x240.jpg 352w, https://sunrise.ug/wp-content/uploads/2022/08/PSX_20220809_091504-300x206.jpg 300w" sizes="(max-width: 352px) 100vw, 352px" />									<img width="100" height="100" src="https://sunrise.ug/wp-content/uploads/2022/08/PSX_20220809_091504-100x100.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://sunrise.ug/wp-content/uploads/2022/08/PSX_20220809_091504-100x100.jpg 100w, https://sunrise.ug/wp-content/uploads/2022/08/PSX_20220809_091504-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" />																							</div><!--mvp-main-blog-img-->
							</a>
							<div class="mvp-main-blog-in">
								<div class="mvp-main-blog-text left relative">
									<h3 class="mvp-main-blog-cat left"><span class="mvp-main-blog-cat left">Brian Mukalazi</span></h3>
									<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/lessons-from-the-mbale-floods-disaster.html" rel="bookmark"><h2>Lessons from the Mbale floods disaster</h2></a>
									<div class="mvp-feat1-info">
										<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><time class="mvp-blog-time">August 9, 2022</time></span>
									</div><!--mvp-feat1-info-->
									<p>By the time of writing this, the number of people confirmed dead from the fatal flash...</p>
									<div class="mvp-story-share-wrap">
										<span class="mvp-story-share-but fa fa-share fa-2"></span>
										<div class="mvp-story-share-cont">
											<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/lessons-from-the-mbale-floods-disaster.html&t=Lessons from the Mbale floods disaster', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mvp-story-share-fb fa fa-facebook fa-2"></span></a>
											<a href="#" onclick="window.open('http://twitter.com/share?text=Lessons from the Mbale floods disaster -&url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/lessons-from-the-mbale-floods-disaster.html', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mvp-story-share-twit fa fa-twitter fa-2"></span></a>
											<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/lessons-from-the-mbale-floods-disaster.html&amp;media=https://sunrise.ug/wp-content/uploads/2022/08/PSX_20220809_091504.jpg&amp;description=Lessons from the Mbale floods disaster', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mvp-story-share-pin fa fa-pinterest-p fa-2"></span></a>
										</div><!--mvp-story-share-cont-->
									</div><!--mvp-story-share-wrap-->
								</div><!--mvp-main-blog-text-->
							</div><!--mvp-main-blog-in-->
						</div><!--mvp-main-blog-out-->
					</li>
											<li>
						<div class="mvp-main-blog-out relative">
							<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/its-tough-being-a-ugandan.html" rel="bookmark">
							<div class="mvp-main-blog-img left relative">
																	<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/07/A-recent-IPC-report-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" />									<img width="100" height="100" src="https://sunrise.ug/wp-content/uploads/2022/07/A-recent-IPC-report-100x100.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://sunrise.ug/wp-content/uploads/2022/07/A-recent-IPC-report-100x100.jpg 100w, https://sunrise.ug/wp-content/uploads/2022/07/A-recent-IPC-report-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" />																							</div><!--mvp-main-blog-img-->
							</a>
							<div class="mvp-main-blog-in">
								<div class="mvp-main-blog-text left relative">
									<h3 class="mvp-main-blog-cat left"><span class="mvp-main-blog-cat left">Brian Mukalazi</span></h3>
									<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/its-tough-being-a-ugandan.html" rel="bookmark"><h2>It’s tough being a Ugandan!</h2></a>
									<div class="mvp-feat1-info">
										<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><time class="mvp-blog-time">July 26, 2022</time></span>
									</div><!--mvp-feat1-info-->
									<p>When the Ministry of Health and the Uganda Counselling Association reported in May that nearly 14...</p>
									<div class="mvp-story-share-wrap">
										<span class="mvp-story-share-but fa fa-share fa-2"></span>
										<div class="mvp-story-share-cont">
											<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/its-tough-being-a-ugandan.html&t=It’s tough being a Ugandan!', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mvp-story-share-fb fa fa-facebook fa-2"></span></a>
											<a href="#" onclick="window.open('http://twitter.com/share?text=It’s tough being a Ugandan! -&url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/its-tough-being-a-ugandan.html', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mvp-story-share-twit fa fa-twitter fa-2"></span></a>
											<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/its-tough-being-a-ugandan.html&amp;media=https://sunrise.ug/wp-content/uploads/2022/07/A-recent-IPC-report.jpg&amp;description=It’s tough being a Ugandan!', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mvp-story-share-pin fa fa-pinterest-p fa-2"></span></a>
										</div><!--mvp-story-share-cont-->
									</div><!--mvp-story-share-wrap-->
								</div><!--mvp-main-blog-text-->
							</div><!--mvp-main-blog-in-->
						</div><!--mvp-main-blog-out-->
					</li>
											<li>
						<div class="mvp-main-blog-out relative">
							<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/were-close-to-recession-government-where-are-you.html" rel="bookmark">
							<div class="mvp-main-blog-img left relative">
																	<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/07/PSX_20220712_163624-400x240.jpg" class="mvp-reg-img wp-post-image" alt="" loading="lazy" />									<img width="100" height="100" src="https://sunrise.ug/wp-content/uploads/2022/07/PSX_20220712_163624-100x100.jpg" class="mvp-mob-img wp-post-image" alt="" loading="lazy" srcset="https://sunrise.ug/wp-content/uploads/2022/07/PSX_20220712_163624-100x100.jpg 100w, https://sunrise.ug/wp-content/uploads/2022/07/PSX_20220712_163624-150x150.jpg 150w" sizes="(max-width: 100px) 100vw, 100px" />																							</div><!--mvp-main-blog-img-->
							</a>
							<div class="mvp-main-blog-in">
								<div class="mvp-main-blog-text left relative">
									<h3 class="mvp-main-blog-cat left"><span class="mvp-main-blog-cat left">Brian Mukalazi</span></h3>
									<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/were-close-to-recession-government-where-are-you.html" rel="bookmark"><h2>We’re close to recession; Government where are you?</h2></a>
									<div class="mvp-feat1-info">
										<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><time class="mvp-blog-time">July 12, 2022</time></span>
									</div><!--mvp-feat1-info-->
									<p>“Our economy has faced a complete collapse,&#8221; said Sri Lanka’s embattled Prime Minister Ranil Wickremesinghe recently...</p>
									<div class="mvp-story-share-wrap">
										<span class="mvp-story-share-but fa fa-share fa-2"></span>
										<div class="mvp-story-share-cont">
											<a href="#" onclick="window.open('http://www.facebook.com/sharer.php?u=https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/were-close-to-recession-government-where-are-you.html&t=We’re close to recession; Government where are you?', 'facebookShare', 'width=626,height=436'); return false;" title="Share on Facebook"><span class="mvp-story-share-fb fa fa-facebook fa-2"></span></a>
											<a href="#" onclick="window.open('http://twitter.com/share?text=We’re close to recession; Government where are you? -&url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/were-close-to-recession-government-where-are-you.html', 'twitterShare', 'width=626,height=436'); return false;" title="Tweet This Post"><span class="mvp-story-share-twit fa fa-twitter fa-2"></span></a>
											<a href="#" onclick="window.open('http://pinterest.com/pin/create/button/?url=https://sunrise.ug/opinions/columnists/beautiful-chaos/202207/were-close-to-recession-government-where-are-you.html&amp;media=https://sunrise.ug/wp-content/uploads/2022/07/PSX_20220712_163624.jpg&amp;description=We’re close to recession; Government where are you?', 'pinterestShare', 'width=750,height=350'); return false;" title="Pin This Post"><span class="mvp-story-share-pin fa fa-pinterest-p fa-2"></span></a>
										</div><!--mvp-story-share-cont-->
									</div><!--mvp-story-share-wrap-->
								</div><!--mvp-main-blog-text-->
							</div><!--mvp-main-blog-in-->
						</div><!--mvp-main-blog-out-->
					</li>
										</ul><!--mvp-main-blog-story-->
				</section><!--mvp-main-blog-wrap-->
			</div><!--mvp-post-bot-wrap-->
										<div id="mvp-prev-next-wrap">
											<div id="mvp-prev-post-wrap">
							<div id="mvp-prev-post-arrow" class="relative">
								<i class="fa fa-angle-left fa-4"></i>
							</div><!--mvp-prev-post-arrow-->
							<div class="mvp-prev-next-text">
								<a href="https://sunrise.ug/news/202209/about-uganda-the-drunken-nation.html" rel="prev">About Uganda, the drunken Nation!</a>							</div><!--mvp-prev-post-text-->
						</div><!--mvp-prev-post-wrap-->
														</div><!--mvp-prev-next-wrap-->
						</div><!--mvp-content-left-wrap-->
		</div><!--mvp-content-side-in-->
		<div id="mvp-side-wrap" class="relative theiaStickySidebar">
						<section id="text-8" class="mvp-side-widget widget_text">			<div class="textwidget"><p><a href="https://www.health.go.ug/covid/"><img loading="lazy" class="aligncenter wp-image-34525 size-full" src="https://sunrise.ug/wp-content/uploads/2021/09/COVID19-vaccination-318X334.gif" alt="" width="318" height="334" /></a></p>
</div>
		</section><section id="mvp_ad_widget-8" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SecondSquare -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-8785156633495911"
     data-ad-slot="2461992915"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--mvp-widget-ad-->
		</section><section id="mvp_catlist_widget-3" class="mvp-side-widget mvp_catlist_widget"><h4 class="mvp-side-widget-head left">Columnists</h4>
			<div class="mvp-wide-widget-wrap left relative">
									<div class="mvp-wide-widget-story left relative">
						<a href="https://sunrise.ug/opinions/columnists/isa-senkumba/202210/why-a-few-ugandans-can-afford-the-luxury-of-celebrating-independence-day.html" rel="bookmark">
						<div class="mvp-wide-widget-img left relative">
															<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/10/Ugandans_still_in_bondage-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" />																				</div><!--mvp-wide-widget-img-->
						</a>
						<div class="mvp-wide-widget-text left relative">
															<h3 class="mvp-feat2-sub-cat left"><span class="mvp-feat2-sub-cat left">Isa Senkumba</span></h3>
														<a href="https://sunrise.ug/opinions/columnists/isa-senkumba/202210/why-a-few-ugandans-can-afford-the-luxury-of-celebrating-independence-day.html" rel="bookmark"><h2>Why a few Ugandans can afford the luxury of celebrating Independence Day</h2></a>
							<div class="mvp-feat1-info">
								<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/isenkumba" title="Posts by Isa Senkumba" rel="author">Isa Senkumba</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><span class="mvp-blog-time">October 12, 2022</span></span>
							</div><!--mvp-feat1-info-->
						</div><!--mvp-wide-widget-text-->
					</div><!--mvp-wide-widget-story-->
									<div class="mvp-wide-widget-story left relative">
						<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html" rel="bookmark">
						<div class="mvp-wide-widget-img left relative">
															<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/10/Aga-Ssekalala-clip-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" />																				</div><!--mvp-wide-widget-img-->
						</a>
						<div class="mvp-wide-widget-text left relative">
															<h3 class="mvp-feat2-sub-cat left"><span class="mvp-feat2-sub-cat left">Brian Mukalazi</span></h3>
														<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202210/uganda60-its-a-story-of-shared-dreams-and-struggles.html" rel="bookmark"><h2>Uganda@60: It’s a story of shared dreams and struggles</h2></a>
							<div class="mvp-feat1-info">
								<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><span class="mvp-blog-time">October 9, 2022</span></span>
							</div><!--mvp-feat1-info-->
						</div><!--mvp-wide-widget-text-->
					</div><!--mvp-wide-widget-story-->
									<div class="mvp-wide-widget-story left relative">
						<a href="https://sunrise.ug/opinions/columnists/isa-senkumba/202209/is-it-fair-to-present-the-dead-before-a-public-court.html" rel="bookmark">
						<div class="mvp-wide-widget-img left relative">
															<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/08/PSX_20220825_130726-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" />																				</div><!--mvp-wide-widget-img-->
						</a>
						<div class="mvp-wide-widget-text left relative">
															<h3 class="mvp-feat2-sub-cat left"><span class="mvp-feat2-sub-cat left">Isa Senkumba</span></h3>
														<a href="https://sunrise.ug/opinions/columnists/isa-senkumba/202209/is-it-fair-to-present-the-dead-before-a-public-court.html" rel="bookmark"><h2>Is it FAIR to present the dead before a public court?</h2></a>
							<div class="mvp-feat1-info">
								<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/isenkumba" title="Posts by Isa Senkumba" rel="author">Isa Senkumba</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><span class="mvp-blog-time">September 7, 2022</span></span>
							</div><!--mvp-feat1-info-->
						</div><!--mvp-wide-widget-text-->
					</div><!--mvp-wide-widget-story-->
									<div class="mvp-wide-widget-story left relative">
						<a href="https://sunrise.ug/news/202209/about-uganda-the-drunken-nation.html" rel="bookmark">
						<div class="mvp-wide-widget-img left relative">
															<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/09/PSX_20220906_123805-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" />																				</div><!--mvp-wide-widget-img-->
						</a>
						<div class="mvp-wide-widget-text left relative">
															<h3 class="mvp-feat2-sub-cat left"><span class="mvp-feat2-sub-cat left">Brian Mukalazi</span></h3>
														<a href="https://sunrise.ug/news/202209/about-uganda-the-drunken-nation.html" rel="bookmark"><h2>About Uganda, the drunken Nation!</h2></a>
							<div class="mvp-feat1-info">
								<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><span class="mvp-blog-time">September 6, 2022</span></span>
							</div><!--mvp-feat1-info-->
						</div><!--mvp-wide-widget-text-->
					</div><!--mvp-wide-widget-story-->
									<div class="mvp-wide-widget-story left relative">
						<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/ugandas-job-market-its-about-who-you-know.html" rel="bookmark">
						<div class="mvp-wide-widget-img left relative">
															<img width="400" height="240" src="https://sunrise.ug/wp-content/uploads/2022/08/Uganda-Airlines_CEO-Jennifer-Bamuturaki-and-COSASE-Chair-Joel-Ssenyonyi-400x240.jpg" class="attachment-mvp-mid-thumb size-mvp-mid-thumb wp-post-image" alt="" loading="lazy" />																				</div><!--mvp-wide-widget-img-->
						</a>
						<div class="mvp-wide-widget-text left relative">
															<h3 class="mvp-feat2-sub-cat left"><span class="mvp-feat2-sub-cat left">Brian Mukalazi</span></h3>
														<a href="https://sunrise.ug/opinions/columnists/beautiful-chaos/202208/ugandas-job-market-its-about-who-you-know.html" rel="bookmark"><h2>Uganda’s job market: It’s about who you know!</h2></a>
							<div class="mvp-feat1-info">
								<span class="mvp-blog-author">By <a href="https://sunrise.ug/author/brian-mukalazi" title="Posts by Brian Mukalazi" rel="author">Brian Mukalazi</a></span><span class="mvp-blog-date"><i class="fa fa-clock-o"></i><span class="mvp-blog-time">August 22, 2022</span></span>
							</div><!--mvp-feat1-info-->
						</div><!--mvp-wide-widget-text-->
					</div><!--mvp-wide-widget-story-->
							</div><!--mvp-wide-widget-wrap-->

		</section><section id="text-4" class="mvp-side-widget widget_text">			<div class="textwidget"><p><a href="#"><img loading="lazy" src="https://sunrise.ug/Ads/solar.gif" alt="solar" width="300″ height=" name="solar" /></a></p>
</div>
		</section><section id="mvp_ad_widget-4" class="mvp-side-widget mvp_ad_widget">			<div class="mvp-widget-ad left relative">
				<span class="mvp-ad-label">Advertisement</span>
				<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- SquareBanner -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-8785156633495911"
     data-ad-slot="8476736920"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>			</div><!--mvp-widget-ad-->
		</section>			</div><!--mvp-side-wrap-->	</div><!--mvp-content-side-out-->
</div><!--mvp-post-area-->
													<div id="mvp-foot-ad-wrap" class="left relative">
								<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- leaderboard -->
<ins class="adsbygoogle"
     style="display:inline-block;width:728px;height:90px"
     data-ad-client="ca-pub-8785156633495911"
     data-ad-slot="8091595324"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>							</div><!--mvp-foot-ad-wrap-->
											</div><!--mvp-main-content-wrap-->
				</div><!--mvp-main-in-->
			</div><!--mvp-main-out-->
		</div><!--mvp-main-boxed-wrap-->
	</div><!--mvp-main-wrap-->
	<footer id="mvp-foot-wrap" class="left relative">
		<div id="mvp-foot-top-wrap" class="left relative">
			<div class="mvp-main-out relative">
				<div class="mvp-main-in">
					<div class="mvp-foot-in-wrap left relative">
						<ul class="mvp-foot-soc-list left relative">
															<li><a href="https://www.facebook.com/sunriseug" target="_blank" class="fa fa-facebook-official fa-2"></a></li>
																						<li><a href="https://twitter.com/TheSunriseUg" target="_blank" class="fa fa-twitter fa-2"></a></li>
																																																							</ul>
						<div id="mvp-foot-nav" class="left relative">
							<div class="menu-aboutus-container"><ul id="menu-aboutus" class="menu"><li id="menu-item-1267" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1267"><a href="https://sunrise.ug/about">About us</a></li>
<li id="menu-item-1270" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1270"><a href="https://sunrise.ug/about/our-staff">Our Staff</a></li>
<li id="menu-item-1271" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1271"><a href="https://sunrise.ug/about/employment-opportunities">Careers</a></li>
<li id="menu-item-1273" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1273"><a href="https://sunrise.ug/contact-us">Contact Us</a></li>
<li id="menu-item-1276" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1276"><a href="https://sunrise.ug/contact-us/support">Support</a></li>
</ul></div>						</div><!--mvp-foot-nav-->
					</div><!--mvp-foot-in-wrap-->
				</div><!--mvp-main-in-->
			</div><!--mvp-main-out-->
		</div><!--mvp-foot-top-wrap-->
		<div id="mvp-foot-bot-wrap" class="left relative">
			<div class="mvp-main-out relative">
				<div class="mvp-main-in">
					<div class="mvp-foot-in-wrap left relative">
						<div id="mvp-foot-copy" class="left relative">
							<p>Copyright © 2022 Sunrise Newspaper</p>
						</div><!--mvp-foot-copy-->
					</div><!--mvp-foot-in-wrap-->
				</div><!--mvp-main-in-->
			</div><!--mvp-main-out-->
		</div><!--mvp-foot-bot-wrap-->
	</footer>
</div><!--mvp-site-->
<div class="mvp-fly-top back-to-top">
	<i class="fa fa-angle-up fa-3"></i>
	<span class="mvp-fly-top-text">To Top</span>
</div><!--mvp-fly-top-->
<div class="mvp-fly-fade mvp-fly-but-click">
</div><!--mvp-fly-fade-->
<script type='text/javascript' id='ppress-frontend-script-js-extra'>
/* <![CDATA[ */
var pp_ajax_form = {"ajaxurl":"https:\/\/sunrise.ug\/wp-admin\/admin-ajax.php","confirm_delete":"Are you sure?","deleting_text":"Deleting...","deleting_error":"An error occurred. Please try again.","nonce":"a9f42bb96f","disable_ajax_form":"false","is_checkout":"0","is_checkout_tax_enabled":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://sunrise.ug/wp-content/plugins/wp-user-avatar/assets/js/frontend.min.js?ver=4.2.0' id='ppress-frontend-script-js'></script>
<script type='text/javascript' src='https://sunrise.ug/wp-content/themes/sunrise1/js/scripts.js?ver=6.0.2' id='clickmag-js'></script>
<script type='text/javascript' src='https://sunrise.ug/wp-content/themes/sunrise1/js/retina.js?ver=6.0.2' id='retina-js'></script>
<script type='text/javascript' src='https://sunrise.ug/wp-content/themes/sunrise1/js/mvpcustom.js?ver=6.0.2' id='mvp-custom-js'></script>
<script type='text/javascript' id='mvp-custom-js-after'>

	jQuery(document).ready(function($) {
  	$(window).load(function(){
	var aboveHeight = $("#mvp-head-top").outerHeight();
	var previousScroll = 0;
	    $(window).scroll(function(event){
			var scroll = $(this).scrollTop();
			var elementOffset = $("#mvp-post-content-mid").offset().top;
			var distance = (elementOffset - scroll);
	    	if ($(window).scrollTop() > aboveHeight){
	    		$("#mvp-nav-wrap").addClass("mvp-fixed").css("top","0");
	    		$("#mvp-main-wrap").addClass("mvp-fixed-next");
	    		if(scroll < previousScroll) {
					$(".mvp-fly-top").addClass("mvp-to-top");
				} else {
					$(".mvp-fly-top").removeClass("mvp-to-top");
				}
	    	} else {
	    		$("#mvp-nav-wrap").removeClass("mvp-fixed");
	    		$("#mvp-main-wrap").removeClass("mvp-fixed-next");
	    		$(".mvp-fly-top").removeClass("mvp-to-top");
	    	}
	    	if (distance < 60){
	    		if(scroll > previousScroll) {
					$("#mvp-nav-soc-bar").addClass("mvp-nav-soc-down");
				} else {
					$("#mvp-nav-soc-bar").removeClass("mvp-nav-soc-down");
				}
			}
			previousScroll = scroll;
		});
	});
	});
	

	jQuery(document).ready(function($) {
	// Main Menu Dropdown Toggle
	$(".menu-item-has-children a").click(function(event){
	  event.stopPropagation();
	  location.href = this.href;
  	});

	$(".menu-item-has-children").click(function(){
    	  $(this).addClass("toggled");
    	  if($(".menu-item-has-children").hasClass("toggled"))
    	  {
    	  $(this).children("ul").toggle();
	  $(".mvp-fly-nav-menu").getNiceScroll().resize();
	  }
	  $(this).toggleClass("tog-minus");
    	  return false;
  	});

	// Main Menu Scroll
	$(window).load(function(){
	  $(".mvp-fly-nav-menu").niceScroll({cursorcolor:"#888",cursorwidth: 7,cursorborder: 0,zindex:999999});
	});
	});
	

	jQuery(document).ready(function($) {
	$(".infinite-content").infinitescroll({
	  navSelector: ".mvp-nav-links",
	  nextSelector: ".mvp-nav-links a:first",
	  itemSelector: ".infinite-post",
	  errorCallback: function(){ $(".mvp-inf-more-but").css("display", "none") }
	});
	$(window).unbind(".infscr");
	$(".mvp-inf-more-but").click(function(){
   		$(".infinite-content").infinitescroll("retrieve");
        	return false;
	});
	$(window).load(function(){
		if ($(".mvp-nav-links a").length) {
			$(".mvp-inf-more-but").css("display","inline-block");
		} else {
			$(".mvp-inf-more-but").css("display","none");
		}
	});
	});
	
</script>
<script type='text/javascript' src='https://sunrise.ug/wp-content/themes/sunrise1/js/flexslider.js?ver=6.0.2' id='flexslider-js'></script>
<script type='text/javascript' src='https://sunrise.ug/wp-content/themes/sunrise1/js/jquery.infinitescroll.min.js?ver=6.0.2' id='infinitescroll-js'></script>
<!-- Facebook Comments Plugin for WordPress: http://peadig.com/wordpress-plugins/facebook-comments/ -->
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=275960799532366&version=v2.3";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
</body>
</html>
<!-- Dynamic page generated in 0.912 seconds. -->
<!-- Cached page generated by WP-Super-Cache on 2022-10-13 09:17:17 -->

<!-- super cache -->